Toad Extension for Eclipse Forum - Toad Extension for Eclipse - Toad World

Toad Extension for Eclipse Forum

Danny Torres

We are now on Twitter!!! Contact a Technical Support expert today...

Expand content
Do you have a quick support question and short of time? Contact us Via Twitter @ QuestExperts and we will take care of you. #Jointheinnovation #WeareQuest

Do you have a quick support question and short of time? Contact us Via Twitter  @QuestExperts and we will take care of you. #Jointheinnovation #WeareQuest

448 0 / Create an account to join the discussion.
adam.m.mcelhinney
Follow / 3 Nov 2014 at 11:47pm / Toad Extension for Eclipse
Latest post by on 18 Apr 2017 at 2:49pm

SQL Problems Window Background is all black

Expand content
I am an Eclipse noob, so apologize if these are dumb questions. Running Eclipse Luna 4.4.1 with Java 1.7.0_72. The SQL Problems window in the Toad for Eclipse plug-in has black text with a black background...

I am an Eclipse noob, so apologize if these are dumb questions.

Running Eclipse Luna 4.4.1 with Java 1.7.0_72.

The SQL Problems window in the Toad for Eclipse plug-in has black text with a black background. I have gone through all of the different preferences I can find in Eclipse and I cannot find one that changes this background to be another color. 

Does anyone know how to do this?

Secondarily, when I execute many-line queries, the error statement is displayed in the SQL Problems window at the top, with the whole text of the query at the bottom. This means that I have to scroll to the top everytime I want to view the error message (I also have to highlight the section, because its black text on a black background, per my first question). Does anyone know a fix for these issues? 

Thanks so much for the help.

Unanswered 11914 5 / Create an account to join the discussion.
Daniel K.
Follow / 28 Mar 2017 at 3:00pm / Toad Extension for Eclipse

TEE opens up multiple connections to Oracle Db. Why?

Expand content
Hi, TEE is a great tool, but there is something me and my DBA do not understand. When I open up seemingly one connection in eclipse, TEE actually opens up three connections (I can monitor this via nettop...

Hi,

TEE is a great tool, but there is something me and my DBA do not understand. When I open up seemingly one connection in eclipse, TEE actually opens up three connections (I can monitor this via nettop on my device and my DBA also sees them on the server). The amount of connections can get even bigger and TEE seems to open and close some of them without obvious reasons for me as the user. As this of course means an overhead for our database, we would like to understand what causes TEE to do this. Is it some feature I could turn off? Do I trigger this with something I am not aware of? Even if I could not switch it off it would be nice to understand why this is happening.

Any hint is appreciated! Thanks.

PS. This was tested on a mac book pro 10.12.3 and an Ubuntu 16.04 - with the same results.

Best regards,

Daniel

63 0 / Create an account to join the discussion.
Russell_Nash
Follow / 22 Mar 2017 at 8:43am / Toad Extension for Eclipse

Syntax error using PostgreSQL/Postgis

Expand content
Hi, I am using the Toad Extension with PostgreSQL/Postgis. When creation the geometry column using something like "geom geometry (Polygon, 31467)" I always get a Syntax error Execution...

Hi,

I am using the Toad Extension with PostgreSQL/Postgis.

When creation the geometry column using something like "geom geometry (Polygon, 31467)" I always get a Syntax error

Execution works fine. It is just a little bit annoying.

Any tips to solve this?

Unanswered 56 0 / Create an account to join the discussion.
mattcsl
Follow / 21 Feb 2017 at 6:44pm / Toad Extension for Eclipse

HIghlight Occurrences?

Expand content
Does SQL Worksheet editor have anyway to highlight all occurrences of a selected word/keyword? How do I configure this?

Does SQL Worksheet editor have anyway to highlight all occurrences of a selected word/keyword? How do I configure this?

136 0 / Create an account to join the discussion.
gggaaa
Follow / 12 Feb 2017 at 7:09am / Toad Extension for Eclipse

Queries are executed but no output is printed (PostgreSQL)

Expand content
I'm able to connect and execute queries on a PostreSQL DB. But I cannot see any output. For example: DO $$ Begin raise notice 'Hi world'; END$$ Runs successfully (appears on SQL Recall...

I'm able to connect and execute queries on a PostreSQL DB. But I cannot see any output.

For example:

DO $$
Begin
raise notice 'Hi world';
END$$

Runs successfully (appears on SQL Recall window with a green icon), but I can't find the output anywhere (DBMS Output, SQL monitor, DB Problems, DB Console, Result).

On PGAdmin, such messages appear under "Messages" window.

Moreover, on PGAdmin I get all the messages regarding creation\deletion of tables (every queries output) which is missing in Toad.

Any ideas?

My Setup:

JDBC driver: 9.4.1212 (9.4)

PostgreSQL 9.4

Latest version of Toad.

Eclipse Version: Neon.2 Release (4.6.2).

184 0 / Create an account to join the discussion.
JanD
Follow / 21 Feb 2016 at 11:17am / Toad Extension for Eclipse
Latest post by on 7 Feb 2017 at 12:15am

TEE 2.3.6: Paste is not working

Expand content
After Update to 2.3.6 I'm not able to paste any text from clipboard into the toad-editor(s) (SQL-Worksheet, Stored Procedure Editor. Copy works as I can copy text from toad-editor and paste it somewhere...

After Update to 2.3.6 I'm not able to paste any text from clipboard into the toad-editor(s) (SQL-Worksheet, Stored Procedure Editor.

Copy works as I can copy text from toad-editor and paste it somewhere else (eclipse standard texteditor)

As I go back to 2.3.4 paste works as expected.

Happens only if I open a sql-file from project without toad-nature AND do not open any sql-file from a project with toad nature-before.

  • Ubuntu 14.04.1
  • Eclipse Luna.1
  • Oracle Java7

BTW: The new version 2.3.6 makes a very stable impression. GOOD JOB!

Jan

Unanswered 2501 5 / Create an account to join the discussion.
jc1224
Follow / 23 Jan 2017 at 1:20pm / Toad Extension for Eclipse

Data Grid DOES NOT work - NEED HELP

Expand content
Hello, i have Eclipse Version: Neon.2 Release (4.6.2). Installed Toad™ Extension for Eclipse - Community Edition 2.4.4.201607260946 com.dell.toadext.feature.feature.group Dell. I use Toad...

Hello,

i have Eclipse Version: Neon.2 Release (4.6.2).

Installed Toad™ Extension for Eclipse - Community Edition 2.4.4.201607260946 com.dell.toadext.feature.feature.group Dell.

I use Toad more than 1 year now in Version: Mars.1 Release (4.5.1).

But with the new Eclipse or the new Toad the data grid (where clause) does not work.

Normally when I did write here    my condition in the data grid only the results regarding the where clause were shown.

NOW: The data grid shows ALL rows. But does not use the where clause. Is does simple nothing - as if it would not exist. Or deactivated.

Can someone help me?

Unanswered 238 0 / Create an account to join the discussion.
ssnyder
Follow / 16 Dec 2016 at 3:33pm / Toad Extension for Eclipse
Latest post by on 17 Jan 2017 at 9:44pm

Mongo - Message when using aggregate(): Cannot use 'commands'...

Expand content
How can I set it up to use an older version of the client? I've tried setting a compatible java driver but it doesn't matter. I get the message when I try to do a query using aggregate()....not...

How can I set it up to use an older version of the client?  I've tried setting a compatible java driver but it doesn't matter.

I get the message when I try to do a query using aggregate()....not when I use find().

Running version() - I get 3.2.4

db.version() - I get 3.0.10

I've got v 3.0.4 java driver selected in the connection properties, but it doesn't seem to change it.

Thanks.

592 1 / Create an account to join the discussion.
Robert Munteanu

Preventing the 'Database Settings' welcome dialog from ap...

Expand content
Hi, When starting up with a new workspace and Toad for Eclipse installed I always get the dialog to select the database engine I'm working for. The thing is: Toad is not a central part of my...

Hi,


When starting up with a new workspace and Toad for Eclipse installed I always get the dialog to select the database engine I'm working for.

The thing is:

  1. Toad is not a central part of my workflow, so I'd rather configure it when needed - the popup is quite intrusive
  2. I have already configured the preferences in the workspace using Eclipse Oomph - the 'toadext.defaultNewConnection' property is set to MYSQL

What can I do to prevent the welcome dialog from Toad from appearing?

Thanks,


Robert

Unanswered 196 0 / Create an account to join the discussion.
Anonymous
Follow / 24 Nov 2016 at 2:57am / Toad Extension for Eclipse
Latest post by Anonymous on 16 Dec 2016 at 5:23am

Toad extension for Eclipse stuck loading Oracle table columns

Expand content
The Toad extension (current version, just downloaded 2.4.4.201607260946) seems unable to display any columns of my tables (Oracle 11.2.0.3 using ojdbc6.jar). Eclipse version is neon (4.6, build I20160606...

The Toad extension (current version, just downloaded 2.4.4.201607260946) seems unable to display any columns of my tables (Oracle 11.2.0.3 using ojdbc6.jar). Eclipse version is neon (4.6, build I20160606-1100).

This happens in the Object Explorer...

... as well as in the table viewer/editor...

... and also in the Quick Doc view:

All of them just seem to get stuck on "Loading..." but never return the table's columns.

This happens both in local DBs and in remote ones - connections work fine, I can run queries (though I get an awful lot of NPEs when formatting SQL or triggering auto-completion), but I can't see what columns a table has...

Any way to work around this, or is a fix on the horizon?

Any help would be appreciated, thanks in advance. :-)

Unanswered 447 1 / Create an account to join the discussion.
mmoore
Follow / 13 Dec 2016 at 8:22pm / Toad Extension for Eclipse

Bugs, PostgreSQL Function Script generation

Expand content
CREATE OR REPLACE FUNCTION pxportal_blurb__fgetblurbs_new(IN p_web_site_key_i bigint, IN p_question_set_key_i bigint, IN p_vendor_key_i bigint, IN p_dealer_key_i bigint, IN p_service_key_i bigint, IN p_language_name_i...

CREATE OR REPLACE FUNCTION pxportal_blurb__fgetblurbs_new(IN p_web_site_key_i bigint, IN p_question_set_key_i bigint, IN p_vendor_key_i bigint, IN p_dealer_key_i bigint, IN p_service_key_i bigint, IN p_language_name_i text DEFAULT 'ENGLISH-USA'::text, IN p_blurb_type_codes_i text DEFAULT NULL::text, IN p_blurb_position_i text DEFAULT NULL::text, IN p_article_post_start_date_i timestamp without time zone DEFAULT NULL::timestamp without time zone, IN p_article_post_end_date_i timestamp without time zone DEFAULT NULL::timestamp without time zone, IN p_article_meta_keyword_i text DEFAULT NULL::text, IN p_article_file_name_i text DEFAULT NULL::text, IN p_retrieve_file_blurb_flag_i text DEFAULT 'N'::text, IN p_matching_type_i text DEFAULT 'BROAD'::text, IN p_level_i bigint DEFAULT 2, IN p_subjecthier_i text DEFAULT NULL::text, IN p_qualhier_i text DEFAULT NULL::text, IN p_partition_by2tcode_i text DEFAULT '184420)

The above line was create by 'generate script' The part in yellow should be '184420,98765')

When using pgAdmin III it show correctly.

 

Also,

declare

ss text; --Sql Select clause
sw text; --Sql Where clause
v_language_name tx_language.language_name%type := p_language_name_i;

:= is flagged as a Syntax error. It's not. 

Regards,

Mike

 

202 0 / Create an account to join the discussion.
klopp
Follow / 9 Dec 2016 at 10:23am / Toad Extension for Eclipse

Colors for "where" field

Expand content
How do I change the colors in the "where" field for table view?

How do I change the colors in the "where" field for table view?

Unanswered 201 0 / Create an account to join the discussion.
srattans
Follow / 12 Mar 2012 at 8:50pm / Toad Extension for Eclipse
Latest post by on 11 Nov 2016 at 11:31am

Git Plugin

Expand content
Is there a GIT plugin for TEE?
Is there a GIT plugin for TEE?
12584 2 / Create an account to join the discussion.
paul.harrison_765
Follow / 7 Oct 2016 at 2:00pm / Toad Extension for Eclipse
Latest post by on 26 Oct 2016 at 12:56pm

PLSQL Editor hanging when typing coments

Expand content
Hi I keep coming back to the TOAD plugin for Eclipse and want to use it, but as soon as I start working on my PL/SQL packages, things are either extremely slow or just hang! I have a small package and...

Hi


I keep coming back to the TOAD plugin for Eclipse and want to use it, but as soon as I start working on my PL/SQL packages, things are either extremely slow or just hang! I have a small package and am just trying to type a comment and it just hangs. Two times Iwanted for 20 - 30 seconds for the editor to become active again and now (the thrid time of hanging in 2 min) it just hangs and I need to kill the eclipse service.


Does anybody really use this plugin for extensive PL/SQL development? The rest of the plugin is great! I love the table editors and Worksheets. This I can use for sure, but in the end my main work is PL/SQL development and the editor just doesn't work.

The picture below shows what pops up when I am writing the comment. Then it hangs. For some reason, the colouring changes on each letter I type, this cannot be efficient. Especially when writing comments, anything after a "--" should be a comment.

1288 8 / Create an account to join the discussion.
paul.harrison_765

Text Colors on Stored Procedure Editor not taking effect

Expand content
I am tryng to set colors on the Stored Procedure editor but they are not all taking effect. For example, when I set a color for datatypes, my NUMBER, VARCHAR etc, declerations are still black.

I am tryng to set colors on the Stored Procedure editor but they are not all taking effect. For example, when I set a color for datatypes, my NUMBER, VARCHAR etc, declerations are still black.

633 0 / Create an account to join the discussion.
paul.harrison_765

Outline

Expand content
Unfortunately the Hide Variables option in the outline does not work. I have very large packages with allot of functions/procedures and the outline is pretty much unusable. It would be helpfull if the...

Unfortunately the Hide Variables option in the outline does not work. I have very large packages with allot of functions/procedures and the outline is pretty much unusable. It would be helpfull if the hide variables wold work and it would be great if there was a filter field where we could type some text to filter what is shown in the Outline View. This would make it easier to find the procedures/functions that we need to work on.

667 0 / Create an account to join the discussion.
djije
Follow / 6 Oct 2016 at 9:46am / Toad Extension for Eclipse

Eclipse Outline malfunctionning

Expand content
Hi, In Outline view (for watching the methods and functions of a package), just after having loaded a file, if you go down with the scroll bar, and click on a method (function or procedure), the click...

Hi, 

In Outline view (for watching the methods and functions of a package), just after having loaded a file, if you go down with the scroll bar, and click on a method (function or procedure), the click is not applicated on the method but on the line of the view before scrolling down.

It's a little bit irrating..

I'm using Eclipse Neon, Toad Extension for Eclipse v2.4.4201607260946 on PC Windows 10

Regards.

Djije 

710 0 / Create an account to join the discussion.
escibbe
Follow / 10 Sep 2016 at 8:50pm / Toad Extension for Eclipse
Latest post by on 3 Oct 2016 at 12:10pm

Adding fields to a new MongoDB collection

Expand content
I am running Eclipse with the Toad Extensions as a GUI for MongoDB. After using the Mongo shell to set up my users on an authenticated MongoDB, I turned my attention to using Eclipse. All is well, but...
I am running Eclipse with the Toad Extensions as a GUI for MongoDB. After using the Mongo shell to set up my users on an authenticated MongoDB, I turned my attention to using Eclipse. All is well, but when I created a new Collection and use the Grid view tool to start adding fields, it doesn't work. 
 
When I fill in the Add Field pop-up and then hit OK, nothing happens. The grid remains blank. If I refresh the grid I get this error: "An error has occurred. See error log for more details. java.langNullPointerException."
 
If I go to Code View and copy the script for adding a field and paste it into a Worksheet and Execute the script, I get this error: "Error parsing command line: unrecognized option --host" 
 
Running mongod --help, I see that there is no --host option.
 
I cant update the extensions to 2.4.4 because it keeps telling me some of the repository sites can't be found.
 
Please help! I'm really stuck!
  
Thanks!
Unanswered 1186 2 / Create an account to join the discussion.
edgar.guerrero
Follow / 29 Sep 2016 at 7:36am / Toad Extension for Eclipse
Latest post by on 3 Oct 2016 at 10:06am

Debug store procedures/packages

Expand content
How do I debug/step into etc ?? store procedures/packages

How do I debug/step into etc ??   store procedures/packages

1001 1 / Create an account to join the discussion.