Unable to update data model in Toad Version 3.6

Toad Data Modeler Beta Program Community

Unable to update data model in Toad Version 3.6

Follow / 19 May 2011 at 3:02pm
I am using Toad Data Modeler Version 3.6 .
I am unable to update my data model .
Requirnmet is to update Model B(Old version) with Model A (new version)
I have tried following steps -
1) Reverse engineer my source (A) and destination (B) data model.
2) Tried to merge both data model from sync and convert wizard .
3) Merge model option is replacing/creating replica of source(A) data model with new name XYZ.

For me it seems Merge Model is replacing my destination data model (B).
Model update is also doing same thing as mentioned above .

Waiting for reply with solution.


  • Follow / 19 May 2011 at 3:59pm

    Hi Priyanka,

    as to save time asking plenty of details about your models, it would be best if you send us the two models. Is it OK for you?
    In case you cannot send the models for any reason, the update may be reached only  by AlterScript as Merge will always do replacing of the old objects of same names.


    Message was edited by: Lukas